Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#826 closed defect (fixed)

When resized, UI Demo window turns black

Reported by: Jiri Svoboda Owned by: Jiri Svoboda
Priority: major Milestone: 0.11.1
Component: helenos/unspecified Version: mainline
Keywords: ui Cc:
Blocker for: Depends on:
See also:

Description

When I try to resize UI Demo window (the only rezizable window), it turns black and/or application becomes unstable.

Change History (4)

comment:1 Changed 6 months ago by Jiri Svoboda

Summary: When UI Demo window turns blackWhen resized, UI Demo window turns black

comment:2 Changed 6 months ago by Jiri Svoboda

This only happens if CONFIG_WIN_DOUBLE_BUF=n. In that case we allocate the window bitmap with flag bmpf_direct_output.

The problem is that we allocate the window bitmap before we resize the window. We cannot map the window with the new size before it has been resized, so the operation fails.

We need to allocate the bitmap after the window has been resized. Not sure if it is worth handling each case (direct map or not) separately, or just always allocate the bitmap after the fact.

comment:3 Changed 6 months ago by Jiri Svoboda

Resolution: fixed
Status: assignedclosed

comment:4 Changed 6 months ago by Jakub Jermář

Milestone: 0.9.20.11.1

Milestone renamed

Note: See TracTickets for help on using tickets.