Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 7 months ago

Closed 6 months ago

Last modified 6 months ago

#825 closed defect (fixed)

USB tablet does not work

Reported by: Jiri Svoboda Owned by: Jiri Svoboda
Priority: major Milestone: 0.11.1
Component: helenos/unspecified Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

In current mainline with Qemu 5.0.0/5.2.0 and tools/ew.py, USB tablet does not work. PS/2 mouse is used instead (and mouse pointer gets captured). For comparison I tried running release 0.9.1 with the same arguments and there USB tablet worked. I tried both with Qemu 5.0.0 and 5.2.0 with the same result.

Qemu command-line arguments:

[jirka@omelette build]$ tools/ew.py -d
qemu-system-x86_64 -enable-kvm -drive file=hdisk.img,index=0,media=disk,format=raw -device e1000,netdev=n1 -netdev user,id=n1,hostfwd=udp::8080-:8080,hostfwd=udp::8081-:8081,hostfwd=tcp::8080-:8080,hostfwd=tcp::8081-:8081,hostfwd=tcp::2223-:2223 -usb -device nec-usb-xhci,id=xhci -device usb-tablet -device intel-hda -device hda-duplex -serial stdio -boot d -cdrom image.iso

Here's a diff of devctl output (working vs. non-working case):

@@ -34,12 +33,19 @@
             00:01.1
             00:01.2 : uhci
                 ctl
+                roothub : usbhub
+                    hub
             00:01.3
             00:02.0
             00:03.0 : e1k
                 port0
             00:04.0 : xhci
                 ctl
+                usb1-hs : usbmid
+                    ctl
+                    HID0 : usbhid
+                        mouse
+                        hid
             00:05.0 : hdaudio
                 pcm
             ctl
[jirka@omelette x]$ 

Change History (4)

comment:1 Changed 6 months ago by Jiri Svoboda

Milestone: 0.9.2
Owner: set to Jiri Svoboda
Status: newaccepted

comment:2 Changed 6 months ago by Jiri Svoboda

Bisection shows this problem is caused by commit e037cf3733f322897cbfc63ce44277485f52af9b

commit e037cf3733f322897cbfc63ce44277485f52af9b (HEAD)
Author: Jiri Svoboda <jiri@wiwaxia>
Date:   Tue Dec 29 23:17:21 2020 +0100

    Show kernel console again when its physical area is unmapped
    
    It's good to be able to see the stack trace if e.g. display server
    crashes.

Your honour, I plead guilty.

comment:3 Changed 6 months ago by Jiri Svoboda

Resolution: fixed
Status: acceptedclosed

comment:4 Changed 6 months ago by Jakub Jermář

Milestone: 0.9.20.11.1

Milestone renamed

Note: See TracTickets for help on using tickets.