Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 22 months ago

Closed 9 months ago

Last modified 8 months ago

#704 closed defect (fixed)

Ski and niagara have no kernel console output

Reported by: Jiri Svoboda Owned by:
Priority: major Milestone: 0.8.0
Component: helenos/unspecified Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

Since mainline,2166 ski and niagara have no kernel console output. It was disabled intentionally because since that changeset there is no kernel/userspace arbitration mechanism for console on these platforms.

The problem is that these console devices are not associated with a parea.

This is a bug that needs fixing somehow.

Change History (4)

comment:1 Changed 22 months ago by Jakub Jermář

Milestone: 0.7.1

comment:2 Changed 9 months ago by Jakub Jermář

How about providing a fake parea?

comment:3 Changed 9 months ago by Jiri Svoboda

Resolution: fixed
Status: newclosed

SKI was fixed in cf3a905cae8433ab4e89de18f9432cc8cbaa8deb and a01f7320d7baed06438e7cde66ccddacc299ba1d. Niagara actually does not seem to have this problem, there are two pareas used. Niagara seems to suffer from boot issue #775 instead.

comment:4 Changed 8 months ago by Jakub Jermář

Milestone: 0.8.0
Note: See TracTickets for help on using tickets.