Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 22 months ago

Closed 21 months ago

Last modified 21 months ago

#705 closed defect (worksforme)

Building toolchain fails on gcc after successfully building prerequsites

Reported by: Thomas Owned by: Jiří Zárevúcky
Priority: major Milestone: 0.7.2
Component: helenos/unspecified Version: mainline
Keywords: Cc:
Blocker for: Building HelenOS from sources Depends on:
See also:

Description

Build env:

  • CentOS 7.4 x86_64, i686
  • gcc (GCC) 4.8.5 20150623 (Red Hat 4.8.5-16)
  • GNU Make 3.82

Toolchain building fails with:
checking for objdir… .libs
checking for the correct version of gmp.h… yes
checking for the correct version of mpfr.h… yes
checking for the correct version of mpc.h… yes
checking for the correct version of the gmp/mpfr/mpc libraries… no
configure: error: Building GCC requires GMP 4.2+, MPFR 2.4.0+ and MPC 0.8.0+.
Try the —with-gmp, —with-mpfr and/or —with-mpc options to specify
their locations. Source code for these libraries can be found at
their respective hosting sites as well as at
ftp://gcc.gnu.org/pub/gcc/infrastructure/. See also
http://gcc.gnu.org/install/prerequisites.html for additional info. If
you obtained GMP, MPFR and/or MPC from a vendor distribution package,
make sure that you have installed both the libraries and the header
files. They may be located in separate packages.

Attachments (1)

log.gz (152.3 KB) - added by Thomas 22 months ago.
output of "toolchain.sh ia32"

Download all attachments as: .zip

Change History (8)

Changed 22 months ago by Thomas

Attachment: log.gz added

output of "toolchain.sh ia32"

comment:1 Changed 22 months ago by Jiří Zárevúcky

Owner: set to Jiří Zárevúcky
Status: newaccepted

Thanks for your report. I'll try to fix this asap, the information you provided should help immensely.

comment:2 Changed 21 months ago by Jakub Jermář

Milestone: 0.7.1

comment:3 Changed 21 months ago by Jiří Zárevúcky

Resolution: worksforme
Status: acceptedclosed

Sorry for taking so long.
I installed the same version of CentOS you are using and haven't encountered any problem. I did, however, update the User Guide with some up-to-date hints for preparing your system.

In particular, for installing all required packages, run the following commands as root:

# yum group install 'Development Tools'
# yum install wget texinfo libmpc-devel mpfr-devel gmp-devel PyYAML genisoimage

You shouldn't need to build any dependencies manually. The above is sufficient when using a clean minimal installation of the system as a starting point.

If you still have trouble, don't open a new ticket, but instead visit our IRC channel or send a message to our mailing list, and we'll be happy to help figure out what's the issue. :)

comment:4 Changed 21 months ago by Jiří Zárevúcky

On the off chance that you don't have root access and your sysadmin can't/won't install those libraries for you, there is a really simple way to include the libraries (see https://gcc.gnu.org/wiki/InstallingGCC). In fact, the toolchain script already handles missing isl dependency properly. I didn't bother doing the same for the other libraries, but it would be a nice first patch. :)

comment:5 Changed 21 months ago by Jiří Zárevúcky

Created ticket #709 for that.

comment:6 Changed 21 months ago by Thomas

Hmmmm:

# LANG=CC yum install wget texinfo libmpc-devel mpfr-devel gmp-devel PyYAML genisoimage
Failed to set locale, defaulting to C
Loaded plugins: changelog, versionlock
Package wget-1.14-15.el7_4.1.x86_64 already installed and latest version
Package texinfo-5.1-4.el7.x86_64 already installed and latest version
Package mpfr-devel-3.1.1-4.el7.x86_64 already installed and latest version
Package 1:gmp-devel-6.0.0-15.el7.x86_64 already installed and latest version
Package PyYAML-3.10-11.el7.x86_64 already installed and latest version
Package genisoimage-1.1.11-23.el7.x86_64 already installed and latest version
Nothing to do

Since it is a version not adequate it is chooking on it wont help having the prerequisites installed:

checking for the correct version of gmp.h... yes
checking for the correct version of mpfr.h... yes
checking for the correct version of mpc.h... yes
checking for the correct version of the gmp/mpfr/mpc libraries... no
configure: error: Building GCC requires GMP 4.2+, MPFR 2.4.0+ and MPC 0.8.0+.
Try the --with-gmp, --with-mpfr and/or --with-mpc options to specify
their locations.  Source code for these libraries can be found at
their respective hosting sites as well as at
ftp://gcc.gnu.org/pub/gcc/infrastructure/.  See also
http://gcc.gnu.org/install/prerequisites.html for additional info.  If
you obtained GMP, MPFR and/or MPC from a vendor distribution package,
make sure that you have installed both the libraries and the header
files.  They may be located in separate packages.

It awaits version 2.4.0+ and it gets 3.1.1 what would be ok. But it seems it means to have found 1.1-4 surely less than 2.4.0. There must be some error evaluating version numbers …!

Last edited 21 months ago by Thomas (previous) (diff)

comment:7 Changed 21 months ago by Jakub Jermář

Milestone: 0.7.2
Note: See TracTickets for help on using tickets.