Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 5 years ago

Closed 2 years ago

#589 closed defect (worksforme)

UDP packets corrupted under high load

Reported by: Jakub Jermář Owned by: Jiri Svoboda
Priority: major Milestone: 0.7.1
Component: helenos/net/udp Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

When testing UDP from outside of HelenOS (which runs in QEMU) using the following command:

while true; do echo foo | nc -u localhost 8080; done

some of the packets will arrive with corrupted payload. This can be observed by running:

# netecho -v -p 8080

After some time, netecho will not print "foo" when it receives the packet, but some garbage. The reported size of the payload remains 4 bytes. Sending the UDP datagrams at a slower rate does not exhibit the problem.

Change History (4)

comment:1 Changed 5 years ago by Martin Decky

Milestone: 0.6.00.7.1

comment:2 Changed 2 years ago by Jiri Svoboda

Can you retest this with latest mainline? I was able to reproduce this with mainline,2119, but not with mainline,2729. It could have been fixed by virtue of new UDP API.

comment:3 Changed 2 years ago by Jakub Jermář

Neither I can reproduce this anymore. Looks like the issue is gone or masked. Let's close this as not reproducible.

comment:4 Changed 2 years ago by Jiri Svoboda

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.