Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 5 years ago

Closed 5 years ago

#588 closed defect (fixed)

tcp server crashes when receiving data on newly created connection

Reported by: Agnieszka Tabaka Owned by: Jiri Svoboda
Priority: major Milestone: 0.7.0
Component: helenos/net/tcp Version: mainline
Keywords: tcp connection Cc:
Blocker for: Depends on:
See also:

Description

When connecting using nterm, tcp server immediately closes connection (even before any data was sent or received) without proper disconnect handshake. It crashes when receives any data belonging to this connection from remote side.

How to reproduce that issue:
1) Configure IP address on HelenOS host (either by DHCP or manually)
2) Start netcat on other PC (netcat -l 1234)
3) On HelenOS host: nterm <ip_addr_of_pc> 1234
4) nterm immediately exits due to connection error
5) …however, connection is set up and netcat thinks that connection is active (in Wireshark, there are SYN, SYN/ACK and ACK packets but no RST or FIN)
6) type something in netcat and press enter
7) tcp server in HelenOS crashes

I have tested that on fresh checkout from HelenOS mainline, built with PROFILE=amd64, on VirtualBox? + emulated e1000 card. I'm attaching "tcp" server binary.

Attachments (1)

tcp (211.9 KB) - added by Agnieszka Tabaka 5 years ago.
affected tcp server binary for amd64

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by Agnieszka Tabaka

Attachment: tcp added

affected tcp server binary for amd64

comment:1 Changed 5 years ago by Jakub Jermář

Milestone: 0.5.20.5.1

comment:2 Changed 5 years ago by Martin Decky

Milestone: 0.6.00.7.0

comment:3 Changed 5 years ago by Jakub Jermář

No longer crashes as of mainline,2343, but nterm seems to be able to only send and not receive.

comment:4 Changed 5 years ago by Jiri Svoboda

Resolution: fixed
Status: newclosed

Fixed in mainline,2344.

Note: See TracTickets for help on using tickets.