Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 7 years ago

Closed 7 years ago

#543 closed defect (fixed)

ata_bd crashes when trying to read TOC

Reported by: Jiri Svoboda Owned by:
Priority: major Milestone: 0.6.0
Component: helenos/unspecified Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

When read TOC operation is invoked, ata_bd will crash with null pointer dereference (disk == NULL). This can be reproduced by trying to mount a cdfs, but it renders the system unusable because cdfs hangs in the mount operation. A better way is to read it from somewhere else (working on blkdump extension).

Change History (1)

comment:1 Changed 7 years ago by Jiri Svoboda

Resolution: fixed
Status: newclosed

Fixed in mainline,1846.

Note: See TracTickets for help on using tickets.