Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 13 months ago

Closed 12 months ago

Last modified 12 months ago

#837 closed defect (fixed)

Build error on Fedora 34

Reported by: Jakub Jermář Owned by: Jiří Zárevúcky
Priority: major Milestone:
Component: helenos-build Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

On my Fedora 34 I started getting the following build error on the recent master branch and new build directory:

[1346/2023] Compiling C object uspace/app_launcher.p/app_launcher_launcher.c.o
FAILED: uspace/app_launcher.p/app_launcher_launcher.c.o 
/usr/local/cross/bin/amd64-helenos-gcc -Iuspace/app_launcher.p -I../helenos/uspace/lib/gfximage/include -I../helenos/uspace/lib/gfx/include -Iuspace/lib/pixconv -I../helenos/uspace/lib/pixconv -Iuspace/lib/compress -I../helenos/uspace/lib/compress -I../helenos/uspace/lib/ui/include -I../helenos/uspace/lib/gfxfont/include -I../helenos/uspace/lib/riff/include -I../helenos/uspace/lib/memgfx/include -I../helenos/uspace/lib/display/include -I../helenos/uspace/lib/ipcgfx/include -I../helenos/uspace/lib/congfx/include -fdiagnostics-color=always -D_FILE_OFFSET_BITS=64 -Wall -Winvalid-pch -Wextra -std=gnu11 -imacros /home/jermar/software/HelenOS/build-amd64/config.h -O3 -fexec-charset=UTF-8 -finput-charset=UTF-8 -D_HELENOS_SOURCE -Wa,--fatal-warnings -Wall -Wextra -Werror-implicit-function-declaration -Wwrite-strings -Wunknown-pragmas -Wno-unused-parameter -pipe -ffunction-sections -fno-common -fdebug-prefix-map=/home/jermar/software/HelenOS/helenos=. -Wsystem-headers -fvar-tracking-assignments -Werror -Wmissing-prototypes -Wno-missing-braces -Wno-missing-field-initializers -Wno-unused-parameter -Wno-clobbered -Wno-nonnull-compare -fno-builtin-strftime -isystem../helenos/abi/include -isystem../helenos/abi/arch/amd64/include -isystem../helenos/uspace/lib/c/arch/amd64/include -isystem../helenos/uspace/lib/c/include -D__LE__ -fno-omit-frame-pointer -MD -MQ uspace/app_launcher.p/app_launcher_launcher.c.o -MF uspace/app_launcher.p/app_launcher_launcher.c.o.d -o uspace/app_launcher.p/app_launcher_launcher.c.o -c ../helenos/uspace/app/launcher/launcher.c
../helenos/uspace/app/launcher/launcher.c:53:10: fatal error: images.h: No such file or directory
 #include "images.h"
          ^~~~~~~~~~
compilation terminated.
[1355/2023] Compiling C object uspace/app_mkexfat.p/app_mkexfat_mkexfat.c.o
ninja: build stopped: subcommand failed.

I have meson 0.59.0 and ninja 1.10.2.

Change History (6)

comment:1 Changed 12 months ago by Jakub Jermář

By comparing the command line used for translating launcher on older Fedora and Fedora 34, it turns out that on Fedora 34 the command line is missing the -Iuspace/app/launcher option and so the compiler doesn't know where to find images.h.

On the old Fedora, this option is included right before the -fdiagnostics-color=always option, but is missing on Fedora 34.

Good cmd line from old Fedora:

gcc -Iuspace/f910d3f@@app_launcher@exe -I../../HelenOS.clean/uspace/lib/gfximage/include -I../../HelenOS.clean/uspace/lib/gfx/include -Iuspace/lib/pixconv -I../../HelenOS.clean/uspace/lib/pixconv -Iuspace/lib/compress -I../../HelenOS.clean/uspace/lib/compress -I../../HelenOS.clean/uspace/lib/ui/include -I../../HelenOS.clean/uspace/lib/gfxfont/include -I../../HelenOS.clean/uspace/lib/riff/include -I../../HelenOS.clean/uspace/lib/memgfx/include -I../../HelenOS.clean/uspace/lib/display/include -I../../HelenOS.clean/uspace/lib/ipcgfx/include -I../../HelenOS.clean/uspace/lib/congfx/include -Iuspace/app/launcher -fdiagnostics-color=always -pipe -D_FILE_OFFSET_BITS=64 -std=gnu11 -imacros /home/martin/build/amd64/config.h -O3 -fexec-charset=UTF-8 -finput-charset=UTF-8 -D_HELENOS_SOURCE -Wa,--fatal-warnings -Wall -Wextra -Werror-implicit-function-declaration -Wwrite-strings -Wunknown-pragmas -Wno-unused-parameter -ffunction-sections -fno-common -fdebug-prefix-map=/home/martin/HelenOS.clean=. -Wsystem-headers -fvar-tracking-assignments -Werror -Wmissing-prototypes -Wno-missing-braces -Wno-missing-field-initializers -Wno-unused-parameter -Wno-clobbered -Wno-nonnull-compare -fno-builtin-strftime -isystem../../HelenOS.clean/uspace/lib/c/../../../abi/include -isystem../../HelenOS.clean/uspace/lib/c/../../../abi/arch/amd64/include -isystem../../HelenOS.clean/uspace/lib/c/arch/amd64/include -isystem../../HelenOS.clean/uspace/lib/c/include -D__LE__ -fno-omit-frame-pointer -MD -MQ 'uspace/f910d3f@@app_launcher@exe/app_launcher_launcher.c.o' -MF 'uspace/f910d3f@@app_launcher@exe/app_launcher_launcher.c.o.d' -o 'uspace/f910d3f@@app_launcher@exe/app_launcher_launcher.c.o' -c ../../HelenOS.clean/uspace/app/launcher/launcher.c

Fedora 34:

gcc -Iuspace/app_launcher.p -I../helenos/uspace/lib/gfximage/include -I../helenos/uspace/lib/gfx/include -Iuspace/lib/pixconv -I../helenos/uspace/lib/pixconv -Iuspace/lib/compress -I../helenos/uspace/lib/compress -I../helenos/uspace/lib/ui/include -I../helenos/uspace/lib/gfxfont/include -I../helenos/uspace/lib/riff/include -I../helenos/uspace/lib/memgfx/include -I../helenos/uspace/lib/display/include -I../helenos/uspace/lib/ipcgfx/include -I../helenos/uspace/lib/congfx/include -fdiagnostics-color=always -D_FILE_OFFSET_BITS=64 -Wall -Winvalid-pch -Wextra -std=gnu11 -imacros /home/jermar/software/HelenOS/build-amd64/config.h -O3 -fexec-charset=UTF-8 -finput-charset=UTF-8 -D_HELENOS_SOURCE -Wa,--fatal-warnings -Wall -Wextra -Werror-implicit-function-declaration -Wwrite-strings -Wunknown-pragmas -Wno-unused-parameter -pipe -ffunction-sections -fno-common -fdebug-prefix-map=/home/jermar/software/HelenOS/helenos=. -Wsystem-headers -fvar-tracking-assignments -Werror -Wmissing-prototypes -Wno-missing-braces -Wno-missing-field-initializers -Wno-unused-parameter -Wno-clobbered -Wno-nonnull-compare -fno-builtin-strftime -isystem../helenos/abi/include -isystem../helenos/abi/arch/amd64/include -isystem../helenos/uspace/lib/c/arch/amd64/include -isystem../helenos/uspace/lib/c/include -D__LE__ -fno-omit-frame-pointer -MD -MQ uspace/app_launcher.p/app_launcher_launcher.c.o -MF uspace/app_launcher.p/app_launcher_launcher.c.o.d -o uspace/app_launcher.p/app_launcher_launcher.c.o -c ../helenos/uspace/app/launcher/launcher.c

comment:2 Changed 12 months ago by Jakub Jermář

Owner: set to Jiří Zárevúcky
Status: newassigned

comment:3 Changed 12 months ago by Jiří Zárevúcky

Yes, I can reproduce this on recent Ubuntu as well.

comment:4 Changed 12 months ago by Jiří Zárevúcky

comment:5 Changed 12 months ago by Jiří Zárevúcky

Resolution: fixed
Status: assignedclosed

comment:6 Changed 12 months ago by Jakub Jermář

Thank you, JZr!

Note: See TracTickets for help on using tickets.