Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 3 weeks ago

Closed 2 weeks ago

#813 closed defect (fixed)

Incremental build does not detect changes to uspace/overlay

Reported by: Jiri Svoboda Owned by:
Priority: major Milestone:
Component: helenos-build Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

When I change contents of uspace/overlay (e.g. make install in tools/xcw/demo or install subcommand of hsct or make install-hos in GZX or Sycek source repo, and then run ninja image_path in the HelenOS build directory, the image is not rebuilt.

Change History (3)

comment:1 Changed 3 weeks ago by Jiri Svoboda

I think this might be the cause of CI tests failing .. they don't find the binaries because the OS image does not get updated after the package is installed. See for example http://ci.helenos.org/build-406/logs/test-amd64-coast-sycek-test-yml.log

comment:2 Changed 2 weeks ago by Jiří Zárevúcky

Commit c6ac9a55 should fix this. Can you confirm?

comment:3 Changed 2 weeks ago by Vojtech Horky

Resolution: fixed
Status: newclosed

Yes, that fixed it (build 407 improved a lot), closing. Thanks!

Note: See TracTickets for help on using tickets.