Fork us on GitHub Follow us on Google+ Follow us on Facebook Follow us on Twitter

Opened 5 weeks ago

Closed 5 weeks ago

#767 closed defect (fixed)

No sound on a SMP system

Reported by: Jakub Jermář Owned by:
Priority: major Milestone: 0.8.0
Component: helenos/unspecified Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

Commit:

bf05c7451aebfdd5f9d9f9cba5cc3d3190368378 is the first bad commit
commit bf05c7451aebfdd5f9d9f9cba5cc3d3190368378
Author: Jiří Zárevúcky <zarevucky.jiri@gmail.com>
Date:   Wed Oct 24 19:59:50 2018 +0200

    Fix kernel ubsan

See the attached log.

introduced a regression: no sound on a SMP system running on two CPUs.

Attachments (1)

nosound.log (25.5 KB) - added by Jakub Jermář 5 weeks ago.

Download all attachments as: .zip

Change History (4)

Changed 5 weeks ago by Jakub Jermář

Attachment: nosound.log added

comment:1 Changed 5 weeks ago by Jiri Svoboda

From the log it looks like maybe the HDA driver is not receiving interrupt notifications.

comment:2 Changed 5 weeks ago by Jiří Zárevúcky

My bad. Should be fixed by cbf528f4d2569367997fa6fe4d7410c3f4f94699

comment:3 Changed 5 weeks ago by Jakub Jermář

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.