Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 19 months ago

Closed 19 months ago

Last modified 19 months ago

#702 closed defect (fixed)

Reproducibility improvemens break sparc64/ultra

Reported by: Jiri Svoboda Owned by: Jiří Zárevúcky
Priority: major Milestone: 0.7.1
Component: helenos/unspecified Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

The mainline,2840 (Merge reproducibility improvements) breaks sparc64/ultra. Before this change we can build and run tools/ew.py, the system goes all the way up to the command line. After the fix the build succeeds, but no message is seen after 'Booting the kernel'.

Change History (5)

comment:1 Changed 19 months ago by Jiri Svoboda

Summary: Reproducibility improvemens break sparc54/ultraReproducibility improvemens break sparc64/ultra

comment:2 Changed 19 months ago by Jakub Jermář

Looks like ppc32 and mips32 builds are affected too. Only init tasks are running when the boot stops.

comment:3 Changed 19 months ago by Jiří Zárevúcky

Indeed. I'm looking into it now.

comment:4 Changed 19 months ago by Jiří Zárevúcky

Resolution: fixed
Status: assignedclosed

Fixed in r2850.

The zip file entries are expected to be in the order of dependencies, and I broke that by sorting them… Oops. :)

comment:5 Changed 19 months ago by Jiří Zárevúcky

For the record, arm32 was also affected.

Note: See TracTickets for help on using tickets.