Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 2 years ago

Closed 2 years ago

#695 closed defect (fixed)

e1000_link_restart() needs to be double-checked/tested

Reported by: Jiří Zárevúcky Owned by:
Priority: minor Milestone: 0.7.1
Component: helenos/drv/e1k Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

In uspace/drv/nic/e1k/e1k.c, said function unconditionally calls itself.
I don't know the intended behavior, so I'm leaving this for someone who does.

Change History (2)

comment:1 Changed 2 years ago by Jiří Zárevúcky

Priority: majorminor
Summary: Infinite recursion in e1000_link_restart()e1000_link_restart() needs to be double-checked/tested

I attempted to fix this in r2776.

I haven't tested it in any way, though, so I'm leaving this open with changed summary and lowered priority.

comment:2 Changed 2 years ago by Jiří Zárevúcky

Resolution: fixed
Status: newclosed

The original author (Zdenek Bouska) says the fix seems all right. Closing as fixed.

Note: See TracTickets for help on using tickets.