Fork us on GitHub Follow us on Google+ Follow us on Facebook Follow us on Twitter

Opened 3 years ago

Closed 4 days ago

#642 closed defect (wontfix)

CHT test sometimes hangs in cht_destroy()

Reported by: Jakub Jermář Owned by: Jakub Jermář
Priority: major Milestone:
Component: helenos/kernel/generic Version: mainline
Keywords: rcu, cht, arm, mips, sun4v Cc:
Blocker for: Depends on:
See also:

Description

Revisions including mainline,2396 and earlier sometimes hang at the end of the cht kernel test in cht_destroy(). I can reproduce this with all of the ARM development boards (BeagleBoard XM, BeagleBone, and with the current mainline also on RaspberryPi and GTA02) by running:

kconsole> test cht

multiple times.

Change History (5)

comment:1 Changed 3 years ago by Jakub Jermář

Keywords: arm removed
Summary: CHT test sometimes hangs in cht_destroy() on the ARM boardsCHT test sometimes hangs in cht_destroy()

This is also reproducible with mainline,2399 on msim, so the issue is not ARM-specific.

comment:2 Changed 3 years ago by Jakub Jermář

CHT test also hangs in the CHT preintegration branch on sun4v.

comment:3 Changed 3 years ago by Jakub Jermář

Keywords: arm mips sun4v added

comment:4 Changed 12 months ago by Jakub Jermář

Milestone: 0.7.1

comment:5 Changed 4 days ago by Jakub Jermář

Resolution: wontfix
Status: newclosed

CHT removal was merged in commit 1a5fe4f3ec6a76ebd5b30f992574d843540f25cb

Note: See TracTickets for help on using tickets.