Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 5 years ago

Closed 5 years ago

#618 closed defect (duplicate)

bdsh command options are polluted with command history

Reported by: Michal Koutny Owned by:
Priority: minor Milestone: 0.7.0
Component: helenos/app/bdsh Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also: #506

Description

Version

Local build for ia32 from current mainline (2298). Also the official build of 0.6 and 0.5 (I didn't try older ones).

How to reproduce

In the fresh (/ is working directory) bdsh session type

ls -h<return>
<arrow-up><return>
ls app<return>

Output

  • The first call just prints usage.
  • The second call also prints usage.
  • The third call outputs unknown option — p and lists the current (/) directory.

Expected output

  • The first call just prints usage.
  • The second call also prints usage.
  • The third call lists content of the app directory.

Change History (3)

comment:1 Changed 5 years ago by Vojtech Horky

See also: 506#506

comment:2 Changed 5 years ago by Luka Strižić

This is fixed with the patch from #506.

comment:3 Changed 5 years ago by Jakub Jermář

Milestone: 0.7.0
Resolution: duplicate
Status: newclosed

Closing as duplicate of #506.

Note: See TracTickets for help on using tickets.