Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#585 closed defect (duplicate)

AttributeError: 'NoneType' object has no attribute 'repository'

Reported by: kobiburnley Owned by:
Priority: major Milestone:
Component: helenos-web Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

How to Reproduce

While doing a GET operation on /changeset/current:/mainline, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'format': u'zip',
 'new': u'current:',
 'new_path': u'/mainline',
 'old_path': u'/'}

User agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:28.0) Gecko/20100101 Firefox/28.0

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/trac/web/main.py", line 522, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.7/site-packages/trac/web/main.py", line 243, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.7/site-packages/trac/versioncontrol/web_ui/changeset.py", line 349, in process_request
    self._render_zip(req, filename, repos, data)
  File "/usr/lib/python2.7/site-packages/trac/versioncontrol/web_ui/changeset.py", line 768, in _render_zip
    old_path=data['old_path'], old_rev=data['old_rev']):
  File "/usr/lib/python2.7/site-packages/tracbzr/backend.py", line 744, in get_changes
    old_tree = old_branch.repository.revision_tree(old_revid)
AttributeError: 'NoneType' object has no attribute 'repository'

Change History (2)

comment:1 Changed 5 years ago by Martin Decky

Resolution: duplicate
Status: newclosed

Duplicate of #570

comment:2 Changed 5 years ago by Jakub Jermář

Component: helenos/unspecifiedhelenos-web
Milestone: 0.6.0
Note: See TracTickets for help on using tickets.