Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 6 years ago

Closed 5 years ago

#510 closed defect (worksforme)

Switching between Virtual Console using F1-F11 key

Reported by: Manish Sharma Owned by:
Priority: trivial Milestone: 0.6.0
Component: helenos/unspecified Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

Switching between Virtual Consoles using F1-F11 keys does not work for F10 , although it works for F1-F9 and also for F11 but it doesn't switch its virtual console on pressing F10.

Change History (4)

comment:1 Changed 6 years ago by Manish Sharma

I am using

1) QEMU emulator

2) prepared image ia32- version 0.5.0

3) Keyboard -USB one

comment:2 Changed 6 years ago by Vojtech Horky

I am not able to reproduce this. I tried both simulated USB keyboard in QEMU (i.e. -usb -usbdevice keyboard) and a bridged real one (i.e. -usb -usbdevice host:x.y).

Can you, please, provide some addition details? The whole QEMU command including all parameters, your QEMU version and some details of your USB keyboard would be extremely helpful. Thanks.

Running lsusb in Linux shall display information about connected USB devices. Detail about single device is best displayed with lsbusb -v -s BUS_NUMBER:DEVICE_NUMBER. Attaching the output from lsbusb -v could help us determine whether you are using some special keyboard that reveals a bug in one of our drivers.

It would be also helpful to see whether this problem is still present in current mainline. If you feel up to it, could you, please, compile latest mainline and try to reproduce it there? Thanks.

comment:3 Changed 6 years ago by Martin Decky

Also please make sure that the F10 key does not get actually "swallowed" by your host operating system. For example, there is a known bug in GTK+ 3.4.x and in GNOME 3.4.x which might cause such behaviour (the F10 key binds to opening the main menu or the context menu of any desktop window).

The most straightforward way to test this is to boot a different OS in QEMU (Linux, FreeDOS, you name it) where you know that the F10 key works.

comment:4 Changed 5 years ago by Vojtech Horky

Resolution: worksforme
Status: newclosed

Closing. Not able to reproduce, no additional details provided.

Note: See TracTickets for help on using tickets.