Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 7 years ago

Closed 6 years ago

#478 closed defect (fixed)

Single-pixel line not redrawn in vterm

Reported by: Vojtech Horky Owned by:
Priority: major Milestone: 0.6.0
Component: helenos/gui/compositor Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

The problem is best described by the attached picture.

The bug was initially reported through mailing-list, posting excerpt here for quick-reference.

When playing tetris 90 deg rotated, a single-pixel line remains drawn
in previous position of the falling block. Screenshot is attached. But
I am not sure that this is not something related rather to Qemu than
to your server.

I am also not sure. But my guess is that it is caused by off-by-one
error in damage region calculation inside console server. Another
suspect is nearest-neighbor filtering when it is applied on damage
region coordinates. I will look into it when I will resume working
on my thesis, which I have to put aside for some time because of
other commitments. So for now, let's consider it a known issue.

Attachments (1)

tetris_cube_trace.png (10.6 KB) - added by Vojtech Horky 7 years ago.
Demonstration of the bug (notice window is rotated)

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by Vojtech Horky

Attachment: tetris_cube_trace.png added

Demonstration of the bug (notice window is rotated)

comment:1 Changed 6 years ago by Jakub Jermář

Milestone: 0.5.1
Resolution: fixed
Status: newclosed

Fix merged in mainline,1725.

Note: See TracTickets for help on using tickets.