Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 7 years ago

Last modified 7 months ago

#474 new defect

Mac Pro (Early 2009) UHCI keyboard error

Reported by: Martin Decky Owned by:
Priority: major Milestone:
Component: helenos/srv/kbd Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

The USB 1.1 HID keyboard is not operational on Mac Pro 4.1 (Early 2009) despite being connected via UHCI.

Change History (7)

comment:1 Changed 7 years ago by Jan Vesely

Does this produce some kind of error?
Does UHCI driver use interrupts mode?
if yes, do interrupts work on this machine?

comment:2 in reply to:  1 ; Changed 5 years ago by Jan Vesely

Replying to jvesely:

Does this produce some kind of error?
Does UHCI driver use interrupts mode?
if yes, do interrupts work on this machine?

also, does the keyboard work when connected to to other machines, or qemu, running helenos?

comment:3 in reply to:  2 Changed 5 years ago by Martin Decky

Replying to jvesely:

also, does the keyboard work when connected to to other machines, or qemu, running helenos?

The keyboard works fine in a different PC. Thus the root cause is in the machine which is quite quirky in many ways.

comment:4 Changed 4 years ago by Martin Decky

Milestone: 0.6.00.7.1

comment:5 Changed 19 months ago by Jakub Jermář

Milestone: 0.7.1

comment:6 Changed 15 months ago by Jakub Jermář

Can you try with the latest master (in UP mode)?

comment:7 Changed 7 months ago by Jakub Jermář

Should this ticket be closed?

Note: See TracTickets for help on using tickets.