Fork us on GitHub Follow us on Google+ Follow us on Facebook Follow us on Twitter

Opened 8 years ago

Closed 7 years ago

#333 closed enhancement (fixed)

sparc64 kernel needs to be able to handle TLB misses caused by executing IRQ pseudocode

Reported by: Jakub Jermář Owned by: Jakub Jermář
Priority: major Milestone: 0.5.0
Component: helenos/boot/sparc64 Version:
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

The sparc64 kernel needs to be able to handle TLB misses caused by processing IRQ pseudocode.

The kernel should search the global page hash table while not holding the address space mutex. If there is a hit, the mapping is inserted into TLB and the processing is successful. A miss in this situation is a reason to panic the system or, if running in the context of the pseudocode owner task, kill the current task.

Change History (1)

comment:1 Changed 7 years ago by Jakub Jermář

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.