Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 10 years ago

Closed 10 years ago

#261 closed defect (fixed)

After devman is run, dp8390 gets killed while reading from an I/O port

Reported by: Jakub Jermář Owned by:
Priority: major Milestone: 0.4.3
Component: helenos/kernel/ia32 Version:
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

On the Qemu/ia32 machine with PCI:

If dp8390 starts when devman and its drivers are already running, it gets killed by the kernel during an attempt to read from an I/O port due to a general protection fault.

When devman is not run, then the same version of dp8390 can touch the I/O ports without being killed.

This is reproducible in mainline,656.

Change History (2)

comment:1 Changed 10 years ago by Jakub Jermář

The expected behavior should be either that in both scenarios the I/O operation succeeds or, if beyond the enabled I/O range, generates the fault.

comment:2 Changed 10 years ago by Jakub Jermář

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.