Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 9 years ago

Closed 9 years ago

#208 closed defect (fixed)

Keyboard in console not working when running in VMware

Reported by: Jakub Jermář Owned by:
Priority: major Milestone: 0.4.3
Component: helenos/srv/kbd Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

When running HelenOS/ia32 0.4.2 in VMware, the keyboard does not work in console. It appears to work though when in GRUB and also kconsole during the system is loading (is the mouse driver somehow interfering with it?).

This was reported on VMware Workstation 7.0.0 build-203739 and is also reproducible on my VMware Player 2.5.3 build-185404.

Attachments (1)

madt.png (8.2 KB) - added by Jiri Svoboda 9 years ago.
Message seen during boot.

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by Jiri Svoboda

Attachment: madt.png added

Message seen during boot.

comment:1 Changed 9 years ago by Jiri Svoboda

There is a strange message displayed upon boot that seems to be related to APIC code. Could there be some relation? Keyboard does work in kernel console as well as in versions 0.4.1 and below.

comment:2 Changed 9 years ago by Jiri Svoboda

Resolution: fixed
Status: newclosed

Fixed in changeset:head,319. I am still not quite sure what the problem was. It looks like we were sending the mouse the initialization byte at the wrong moment. Since this code did not belong to i8042 but to char_mouse/ps2 anyway, I moved it and now it works fine in both VMware player 3.0.1 and Qemu 0.8.2 (yes, I have that old Qemu on Windows _).

Note: See TracTickets for help on using tickets.