Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 10 years ago

Closed 10 years ago

#158 closed defect (fixed)

The sparc64 kernel hangs during the fault1 test

Reported by: Jakub Jermář Owned by:
Priority: major Milestone: 0.4.2
Component: helenos/kernel/sparc64 Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

The sparc64 kernel hangs during the fault1 test, which is not the expected behavior. The expected behavior is kernel panic.

Change History (1)

comment:1 Changed 10 years ago by Jakub Jermář

Resolution: fixed
Status: newclosed

Fixed in changeset:head,202.

When the kernel was trying to dump the istate structure during the bad trap caused by the test1
testcase, it tried to map the address in program counter to a symbol. Because the symbol table was
not aligned, it got a memory alignment trap, for which it was trying to dump istate. This generated
another memory alignment trap and so on and so forth.

Note: See TracTickets for help on using tickets.