Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 10 years ago

Closed 8 years ago

#105 closed defect (worksforme)

HelenOS/ppc32 non-debug does not boot (in Qemu)

Reported by: Jakub Jermář Owned by:
Priority: major Milestone: 0.4.3
Component: helenos/kernel/ppc32 Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also: #243

Description

HelenOS/ppc32 non-debug does not boot (in Qemu).
The last displayed message is the loader's:

Booting the kernle…

The debug version boots fine.

Change History (6)

comment:1 Changed 10 years ago by Jakub Jermář

Interestingly enough, I can reproduce this only on my iBook G4 where I have a different version of Qemu. Trying to achieve the same on my Ubuntu desktop does not produce the desired result.

comment:2 Changed 10 years ago by Jakub Jermář

Milestone: 0.4.10.5.0

The problem seems to be specific for Qemu version 0.9.0. Version 0.10.5 does not have this problem. Yesterday I checked that the iBook G4 continues to boot non-debug HelenOS without any problems.

Looks like we can defer this until 0.5.0.

comment:3 Changed 8 years ago by Jakub Jermář

Resolution: worksforme
Status: newclosed

Tested non-debug mainline build with Qemu 0.11.1 and found no problems.
I am thus closing the ticket as worksforme.

comment:4 Changed 8 years ago by Martin Decky

Resolution: worksforme
Status: closedreopened

This is mostly unusual. The kernel ppc32 code is currently heavily broken and even made deliberately unbootable in the process of rewriting. It is probably not related to the original cause of this ticket, but the final result should be the same: It should not actually boot :)

I am reopening the ticket for the time being to keep a track of the ppc32 rewrite.

comment:5 Changed 8 years ago by Jakub Jermář

See also: #243

Hi Martin,

see #243 which tracks the critical bug in the ppc32 exception handling. The problem described by this ticket does not exist. Moreover, the non-debug kernel boots just fine. Just give it a try and then please reclose this ticket.

Thanks,
Jakub

comment:6 Changed 8 years ago by Jakub Jermář

Resolution: worksforme
Status: reopenedclosed

Anyway, going ahead and reclosing this ticket.
The ppc32 exception handling issue is tracked by ticket #243.

Note: See TracTickets for help on using tickets.