Opened 8 months ago

Closed 8 months ago

Last modified 3 months ago

#862 closed defect (fixed)

export.sh produces broken archives with Meson 0.60.0+

Reported by: Jiri Svoboda Owned by:
Priority: major Milestone: 0.14.1
Component: helenos/unspecified Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

Currently trying to build a coastline package or XCW demo fails for me with a message like:

/usr/local/cross/lib/gcc/amd64-helenos/8.2.0/../../../../amd64-helenos/bin/ld: /data/helenos/harbours/build/helenos/lib/libclui.a: error adding symbols: malformed archive

With the updated toolchain the problems stays the same, but the message changes:

/usr/local/cross-2023/lib/gcc/amd64-helenos/13.1.1/../../../../amd64-helenos/bin/ld: /data/helenos/branch/pr226-toolchain_update/build/export/lib/libui.a(/data/helenos/branch/pr226-toolchain_update/build/export/lib/libui.a.p/ui_src_image.c.o): error opening thin archive member: No such file or directory

The archive is a thin archive and the referred file does not exist.

I assume this was caused by the feature introduced in Meson 0.60.0 where thin archives (xxx-ar T) are used automatically, if available. Because during export.sh the .a files are kept, but the .o files are not, we get thin archives with content missing.

Change History (3)

comment:1 by Jiri Svoboda, 8 months ago

Yet another incompatible Meson change that bit us. I'd say maybe it's wrong that we don't require a particular Meson version for building.

comment:2 by Jiri Svoboda, 8 months ago

Resolution: fixed
Status: newclosed

comment:3 by Jiri Svoboda, 3 months ago

Milestone: 0.13.10.14.1

Milestone renamed

Note: See TracTickets for help on using tickets.