Fork us on GitHub Follow us on Facebook Follow us on Twitter

#848 closed defect (worksforme)

Sticking PS/2 mouse in Qemu, unless full-screen

Reported by: Jiri Svoboda Owned by:
Priority: major Milestone: 0.12.1
Component: helenos/unspecified Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

PS/2 mouse in Qemu (i.e. through i8042) tends to stick after moving some distance in Qemu. The problem can be seen on ia32, amd64 or even sparc64/ultra (because Qemu sun4u machine is a PC hybrid with i8042). The problem is normally not seen when running amd64/ia32 with ew.py, because in that case USB tablet is used.

I originally thought this was a bug in Qemu, because it goes away if you switch Qemu to full-screen mode. However…

the problem is reproduced with:

  • HelenOS 0.11.2 / Qemu 5.2.0 .. YES
  • HelenOS 0.11.2 without Window system / Qemu 5.2.0 .. YES
  • HelenOS 0.6.0 / Qemu 5.2.0 .. YES
  • HelenOS 0.5.0 / Qemu 5.2.0 .. NO(!)
  • Windows 3.11 / Qemu 5.2.0 .. NO
  • Windows XP SP2 / Qemu 5.2.0 .. NO
  • SkyOS 5 beta 6947 / Qemu 5.2.0 .. YES

Note that Compositor was introduced in HelenOS 0.6.0 and the problem does not occur with the previous graphical console. Also note that the same problem occurs with SkyOS. It also happens with current HelenOS even with Window System disabled.

Change History (4)

comment:1 Changed 11 months ago by Jiri Svoboda

Also reproduced with Visopsys 0.7 / Qemu 5.0.0

All in all, I think this looks more like a Qemu bug, rather than bug in HelenOS, SkyOS and Visopsys. Therefore, it would make sense to try different versions of Qemu, perhaps it would not be present in an older version.

comment:2 Changed 11 months ago by Jiri Svoboda

I was NOT able to reproduce the problem with HelenOS 0.11.2 / VirtualBox

comment:3 Changed 11 months ago by Jiri Svoboda

With HelenOS 0.11.2, Qemu 2.12.1 and I get a similar problem, but instead of just the mouse sticking, it appears to stick and then Qemu dumps core. The problem is the same regardless if KVM is used or not.

comment:4 Changed 11 months ago by Jiri Svoboda

Milestone: 0.12.1
Resolution: worksforme
Status: newclosed

I cannot reproduce the problem on Qemu 6.2.0, it was probably fixed. Plus the sensitivity of mouse is different with this version.

There is another difference with this version, now the Qemu window contains a menu. Not sure if that is some compilation option (e.g. whether to use GTK) that has changed defaults.

In any case I consider this problem solved.

Note: See TracTickets for help on using tickets.