Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 15 months ago

Closed 2 months ago

#846 closed defect (worksforme)

sparc64/ultra hangs in frame allocator test

Reported by: Jiri Svoboda Owned by:
Priority: major Milestone: 0.12.1
Component: helenos/unspecified Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

If I run all kernel tests from kcon on sparc64/ultra (in Qemu 5.2.0), they hang either in falloc1 or falloc2.

Bisection:

  • head .. HANG (falloc1)
  • 0.11.1 .. HANG (falloc2)
  • 0.9.1 .. HANG (falloc2)
  • 0.7.0 ..does not support serial console

So the problem existed at least since 0.9.1. I cannot easily test before that, because before 0.9.1 we cannot control the OS via serial console.

Change History (2)

comment:1 Changed 15 months ago by Jiri Svoboda

Milestone: 0.12.1

comment:2 Changed 2 months ago by Jakub Jermář

Resolution: worksforme
Status: newclosed

I was not able to reproduce the hang with 0.12.1. I ran test * twice from a -nographic instance and twice from a default instance. Closing for now.

Note: See TracTickets for help on using tickets.