Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 6 weeks ago

Closed 5 weeks ago

Last modified 3 weeks ago

#823 closed defect (fixed)

Closing Terminal running editor or libui application upsets input

Reported by: Jiri Svoboda Owned by: Jiri Svoboda
Priority: major Milestone: 0.11.1
Component: helenos/unspecified Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

When I run 'edit' or a libui application in console mode (-d cons@) and close the terminal using the close button, the mouse goes haywire and i8042 reports buffer overruns in the kernel log.

Change History (4)

comment:1 Changed 5 weeks ago by Jiri Svoboda

Summary: After closing Terminal running editor or libui application upsets inputClosing Terminal running editor or libui application upsets input

comment:2 Changed 5 weeks ago by Jiri Svoboda

Owner: set to Jiri Svoboda
Status: newaccepted

comment:3 Changed 5 weeks ago by Jiri Svoboda

Milestone: 0.9.2
Resolution: fixed
Status: acceptedclosed

The root cause: some applications would drop into an infinite loop if their console connection was broken. This was either because the return value from console_get_event() was not handled properly, or, they were using console_get_event_timeout() for which there is no good way to distinguish between timeout and other error.

This is probably not a new issue. It is possible though, that it was not noticed because it didn't use to disrupt the system's operation. It either surfaced with the new display server or it only happens with i8042 (as opposed to USB hid).

Fixed with this commit.

comment:4 Changed 3 weeks ago by Jakub Jermář

Milestone: 0.9.20.11.1

Milestone renamed

Note: See TracTickets for help on using tickets.