Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 10 months ago

Closed 4 months ago

Last modified 4 months ago

#814 closed defect (fixed)

With Meson build boot images are twice the original size

Reported by: Jakub Jermář Owned by: Jiří Zárevúcky
Priority: blocker Milestone: 0.9.2
Component: helenos-build Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

When building eg. mips32 malta-be, the image.boot size before the switch to meson was 2.6M. After the switch, it is around 5.2M. The large size prevents the image from booting.

Change History (5)

comment:1 Changed 9 months ago by Jiri Svoboda

On amd64 /srv/hid/s3c24xx_ts is now part of the image, so it is actually started(!) and since the device is not self-identifying, it does not even bail out.

Version 0, edited 9 months ago by Jiri Svoboda (next)

comment:2 Changed 4 months ago by Jiří Zárevúcky

Owner: set to Jiří Zárevúcky
Status: newaccepted

Right, so, this is a Meson version issue. There was a change of behavior when it comes to linking and I held off on fixing it to wait if the next version shakes it up some more. For some reason, I added a warning to the compiling wiki page, but didn't add a check to the script or comment about it here. My bad.

Since it looks like linking has been stable for a few months, I'll update the script to work with most recent version.

comment:3 in reply to:  1 Changed 4 months ago by Jiří Zárevúcky

Replying to Jiri Svoboda:

On amd64 /srv/hid/s3c24xx_ts is now part of the image, so it is actually started(!) and since the device is not self-identifying, it does not even bail out. Just thinking this might be a similar kind of a problem.

Seems like some conditionals got lost in the translation by accident. Definitely not intended.

comment:4 Changed 4 months ago by Jiří Zárevúcky

Resolution: fixed
Status: acceptedclosed

Fixed via 18969ce

comment:5 Changed 4 months ago by Jiří Zárevúcky

I did some testing and the only broken version is Meson 0.53.0. I tried to add an explicit check to the build script, but the script actually fails before the check and error message can be reached. I'll just update the comment at the wiki page to warn about this version, but that's all that I can do I think.

Note: See TracTickets for help on using tickets.