Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 11 years ago

Closed 11 years ago

#80 closed defect (fixed)

tmpfs_restore() fails on arm32

Reported by: Jakub Jermář Owned by:
Priority: major Milestone: 0.4.1
Component: helenos/unspecified Version: mainline
Keywords: arm32 Cc:
Blocker for: Depends on:
See also:

Description

As of revision 4435, HelenOS/arm32 will fail to mount the root TMPFS file system due to a problem in tmpfs_restore(). When I investigated the issue, I found out that tmpfs_restore() fails because it reads a bogus entry from the device. What is interesting is that this bogus entry is read after the entire file system (valid data) are successfully restored from the device.

Change History (1)

comment:1 Changed 11 years ago by Jakub Jermář

Resolution: fixed
Status: newclosed

I believe this is a duplicate of ticket #17.
For arm32, this was fixed in revision 4436.

Note: See TracTickets for help on using tickets.