Fork us on GitHub Follow us on Google+ Follow us on Facebook Follow us on Twitter

Opened 7 days ago

Closed 4 days ago

#762 closed defect (wontfix)

cht kernel test hangs on MSIM

Reported by: Jiri Svoboda Owned by: Jakub Jermář
Priority: major Milestone: 0.8.0
Component: helenos/kernel/generic Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also: #642

Description

As of 4a8d0dd1629a42ad3c6e78f6c3807e0c3a00b6b0 the cht test on MSIM appears to hang forever. HelenOS 0.7.2 (i.e. rev. 02458965e345492486c6a3bf78d2e11a99e4315a) seems to be affected as well.

/ # kcon                                                                        kconsole> test *                                                                                                                                                atomic1 (Test atomic operations)                                                Time: 0  user cycles, 1976  kernel cycles                                       Test passed                                                                                                                                                     btree1 (Test B-tree operations)                                                 Inserting keys.                                                                 Printing B-tree:                                                                (48)                                                                            (17,36)(63,82)                                                                  (4,6,10,14)(20,24,28,32)(40,44)(52,55,59)(66,70,74,78)(85,89,93,97)             (0,1,2,3)(4,5)(6,7,8,9)(10,11,12,13)(14,15,16)(17,18,19)(20,21,22,23)(24,25,26,27)(28,29,30,31)(32,33,34,35)(36,37,38,39)(40,41,42,43)(44,45,46,47)(48,49,50,51)(52,53,54)(55,56,57,58)(59,60,61,62)(63,64,65)(66,67,68,69)(70,71,72,73)(74,75,76,77)(78,79,80,81)(82,83,84)(85,86,87,88)(89,90,91,92)(93,94,95,96)(97,98,99,100)
Printing list of leaves:
(0,1,2,3)(4,5)(6,7,8,9)(10,11,12,13)(14,15,16)(17,18,19)(20,21,22,23)(24,25,26,27)(28,29,30,31)(32,33,34,35)(36,37,38,39)(40,41,42,43)(44,45,46,47)(48,49,50,51)(52,53,54)(55,56,57,58)(59,60,61,62)(63,64,65)(66,67,68,69)(70,71,72,73)(74,75,76,77)(78,79,80,81)(82,83,84)(85,86,87,88)(89,90,91,92)(93,94,95,96)(97,98,99,100)
Removing keys.
Printing B-tree:
()
Printing list of leaves:
()
Time: 1248k user cycles, 71621  kernel cycles
Test passed

cht (Concurrent hash table test)
Basic sanity test: ok.
Alloc and init table items. 
Running 2 ins/del/find stress threads + 2 resizers.
I{Joining resize stressers.
I{}}R<R<>I{>I{}}R<R<>I{>I{}}R<R<>I{>I{}}R<R<>I{>I{}}R<R<>I{>I{}}R<R<>I{>I{*}}R<R<>I{>I{}}R<R<>I{>I{}}R<R<>I{>I{}}*R<R<>>Joining op stressers.
1 threads remain
0 threads remain

Change History (2)

comment:1 Changed 7 days ago by Jakub Jermář

Component: helenos/unspecifiedhelenos/kernel/generic
Owner: set to Jakub Jermář
See also: #642

This might be a duplicate of #642.

comment:2 Changed 4 days ago by Jakub Jermář

Resolution: wontfix
Status: newclosed

CHT removal was merged in commit 1a5fe4f3ec6a76ebd5b30f992574d843540f25cb

Note: See TracTickets for help on using tickets.