Fork us on GitHub Follow us on Google+ Follow us on Facebook Follow us on Twitter

Opened 2 weeks ago

#754 new defect

Toolchain build fails with cryptic message when dependecies are missing

Reported by: Jiri Svoboda Owned by:
Priority: major Milestone: 0.8.0
Component: helenos/unspecified Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

I had to reinstall my Fedora 28 and rebuild the HelenOS toolchain. The toolchain build failed. That's expected because a pristine F28 installation does not have all the packages installed that are needed to build it. The problem is, in the past, the build would fail with an error that would easily lead you to which package you are missing. This time, the build failed with cryptic message that left me wondering, complaining about libtool commands failing (but there was no issue with libtool).

I thought toolchain.sh was broken so I went back in history and used older toolchain.sh. That got me useful error messages so I installed the required packages and after a successful toolchain build I tried again with the latest toolchain.sh and it worked.

So the only problem is that it's now impossible to determine what package is missing from the error you get during toolchain build.

889cdb1c2046af9d31d314fa691773fa2e4f9119 Always answer the IPC_M_PHONE_HUNGUP message — BROKEN
e5fe873e6ece249ae475d58dae9a738bfe8b8ea0 Use Travis CI for per-commit builds (#12) — OK

Change History (0)

Note: See TracTickets for help on using tickets.