Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 5 years ago

Last modified 4 years ago

#627 new defect

Atheros Wifi cannot connect

Reported by: Jiri Svoboda Owned by:
Priority: major Milestone:
Component: helenos/unspecified Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

Tried TP-LINK TL-WN722N, forwarded USB device inside Qemu 2.1.0. The device initializes and I get a list of wireless networks. When I try to connect to any I get an error "Timeout when authenticating to network".

Tried both with Open authentication and WPA2-PSK and with different APs.

Change History (2)

comment:1 Changed 5 years ago by Martin Decky

(a) Make sure that you don't have any other NIC configured in the virtual machine. The stack is still somewhat fragile with respect to that.

(b) Please retest it with the original feature branch lp:~kolarik/helenos/ar9271 as it is possible that I have introduced a regression during the coding style cleanup and integration.

comment:2 Changed 4 years ago by Jiri Svoboda

Even without another NIC the behavior is the same. With lp:~kolarik/helenos/ar9271 the result is the same. I also tried on bare metal (on my AMD-based desktop computer). The result was worse, I got error "Device is not in ready state after loading firmware."

Note: See TracTickets for help on using tickets.