Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 5 years ago

Closed 19 months ago

Last modified 19 months ago

#600 closed defect (worksforme)

Makefile.depend needlessly rebuilt every time after a .ag file is changed once

Reported by: Jakub Jermář Owned by: Martin Decky
Priority: minor Milestone: 0.7.1
Component: helenos-build Version: mainline
Keywords: kernel, libc Cc:
Blocker for: Depends on:
See also:

Description

If one touches an *.ag file and then tries to rebuild either the kernel or libc, Makefile.depend will be rebuilt not only on the first run of make, but also on each following one. All but the first rebuilds of Makefile.depend are superfluous and should not be attempted.

Change History (2)

comment:1 Changed 19 months ago by Jakub Jermář

Resolution: worksforme
Status: newclosed

I cannot reproduce this anymore as of mainline,2887.

comment:2 Changed 19 months ago by Jiří Zárevúcky

This was fixed together with the switch to using -MD compiler option.

Note: See TracTickets for help on using tickets.