Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 5 years ago

Closed 5 years ago

#596 closed defect (fixed)

No userspace UI on sun4u Ultra

Reported by: Jiri Svoboda Owned by:
Priority: major Milestone: 0.6.0
Component: helenos/unspecified Version: mainline
Keywords: config Cc:
Blocker for: Depends on:
See also:

Description

As of mainline,2167 when you build sparc64 (ultra) and run it in Qemu 2.1.0, the kernel boots but we end up with kcon's rotating slash. Neither Compositor nor Console take over the screen.

This is a regression. With HelenOS 0.5.0 in Qemu 2.1.0 the graphical console starts and we get a bdsh prompt (although keyboard does not work).

Change History (2)

comment:1 Changed 5 years ago by Jakub Jermář

The problem is that this is a barebone configuration and as such lacks the virtroot and kfb drivers.

comment:2 Changed 5 years ago by Jakub Jermář

Keywords: config added
Resolution: fixed
Status: newclosed

Fixed in mainline,2169.

Note: See TracTickets for help on using tickets.