Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 6 years ago

Closed 22 months ago

#546 closed defect (fixed)

Some DNS lookups fail

Reported by: Martin Decky Owned by: Jiri Svoboda
Priority: major Milestone: 0.7.1
Component: helenos/net/dns Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

DNS lookups of hosts such as "www.d3s.mff.cuni.cz" and "www.mff.cuni.cz" fail even if they shouldn't. Sometimes the first query actually succeeds, but the same query (or even lookups of different hosts) fails subsequently. The zones of the hosts above contain CNAME records which seems to correlate with the issue.

Tested in QEMU 1.0.1 with -net user. The issue is present even in mainline,1818, it does not appear to be a later regression.

Change History (8)

comment:1 Changed 6 years ago by Jiri Svoboda

Hypothesis: The DNS resolver expects to receive both the CNAME and the address record in the reply - it will not send another query to get the address record for a CNAME-only response.

From my location, I get both CNAME and A in response. It could be the case that the responses get merged by my ISP's DNS server, but not by your DNS server - thus the problem could be dependent on the location/chain of DNS servers/resolvers used.

Can you capture the network traffic with Wireshark and post it here, please?

comment:2 Changed 5 years ago by Jiri Svoboda

Alternatively, can you reproduce this with a publicly-accessible DNS server? If so, please provide me with its IP address.

comment:3 Changed 5 years ago by Martin Decky

Milestone: 0.6.00.7.1

comment:4 Changed 4 years ago by Jiri Svoboda

Hi, could you take some time to capture the traffic for me, or determine if this can be reproduced with a publicly-accessible DNS server? Thanks.

comment:5 Changed 23 months ago by Jiri Svoboda

Can you please re-test with mainline,2729? I fixed two cases of memory corruption that could possibly lead to non-deterministic behavior.

If the problem is still reproducible, can you please capture the debug log with max debug level set?

# logset dnsres debug2
# dnsres xxx

Thanks.

comment:6 Changed 23 months ago by Jiri Svoboda

Owner: set to Jiri Svoboda
Status: newaccepted

comment:7 Changed 23 months ago by Jakub Jermář

Works for me on my setup.

comment:8 Changed 22 months ago by Martin Decky

Resolution: fixed
Status: acceptedclosed

Yes, I confirm that it works fine now. I consider this ticket fixed.

Note: See TracTickets for help on using tickets.