Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 7 years ago

Closed 7 years ago

#487 closed defect (fixed)

ipc_cleanup() may get new slammed phones that will prevent its completion

Reported by: Jakub Jermář Owned by: Jakub Jermář
Priority: major Milestone: 0.6.0
Component: helenos/kernel/generic Version: mainline
Keywords: ipc Cc:
Blocker for: Depends on:
See also:

Description

ipc_cleanup() first hangs up all slammed or connected phones, but lets connecting phones to finish the connect transaction, i.e. IPC_M_CONNECT_ME_TO. The idea is that it will hangup these connecting phones later, as soon as they get connected or freed. Now, in theory, the problem is that they can also get slammed by the other side just after the connection is established. In this case, ipc_cleanup() will be still waiting for those to become free or connected, but that will never happen, thus preventing ipc_cleanup() from ever finishing.

Change History (2)

comment:1 Changed 7 years ago by Jakub Jermář

I have a fix for this in lp:~jakub/helenos/camp2012.

comment:2 Changed 7 years ago by Jakub Jermář

Resolution: fixed
Status: newclosed

Fixed in mainline,1665.

Note: See TracTickets for help on using tickets.