Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 9 years ago

Closed 9 years ago

#476 closed defect (fixed)

ext4fs hangs when trying to remove a sparse file

Reported by: Maurizio Lombardi Owned by: Frantisek Princ
Priority: major Milestone:
Component: helenos/fs/other Version: mainline
Keywords: ext4fs Cc:
Blocker for: Depends on:
See also:

Description

The ext4fs hangs when trying to remove a sparse file with size > 4Mb

How to reproduce the bug:

# mkfile -s 5m -p file
# rm file

Attachments (1)

removal_of_sparse_file.png (43.9 KB) - added by Vojtech Horky 9 years ago.
Stack trace in kernel console after trying to remove sparse file

Download all attachments as: .zip

Change History (4)

comment:1 Changed 9 years ago by Frantisek Princ

Owner: changed from Jakub Jermář to Frantisek Princ
Status: newaccepted

Changed 9 years ago by Vojtech Horky

Attachment: removal_of_sparse_file.png added

Stack trace in kernel console after trying to remove sparse file

comment:2 Changed 9 years ago by Vojtech Horky

From the attached screenshot it rather looks that it is VFS that died (task 6 is init:vfs). Run on Qemu with KVM on amd64 build (default configuration except bigger screen and ext4fs as root FS).

Update: tested on latest mainline (1636), but the same problem occurs in 1595 as well (since that revision it is possible to use Ext4 as root FS).

Last edited 9 years ago by Vojtech Horky (previous) (diff)

comment:3 Changed 9 years ago by Martin Decky

Resolution: fixed
Status: acceptedclosed

Fixed in mainline,1638.

Note: See TracTickets for help on using tickets.