Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 7 years ago

Closed 7 years ago

#454 closed defect (worksforme)

HelenOS/mips32/gxemul crashes during boot

Reported by: Jakub Jermář Owned by: Martin Decky
Priority: major Milestone: 0.5.0
Component: helenos/kernel/mips32 Version: mainline
Keywords: gxemul Cc:
Blocker for: Depends on:
See also:

Description

As of mainline,1486, the default barebone GXemul build crashes early during boot:

20430145154-dhc95fk7mhjlozgx)
Built on 2012-05-06 14:18:35 for mips32
Copyright (c) 2001-2012 HelenOS project

Memory statistics
 0x80001000|0x00001000: CPU map
 0x80002000|0x00002000: bootstrap stack
 0x80003000|0x00003000: boot info structure
 0x80100000|0x00100000: kernel entry point
 0x9fc00000|0x1fc00000: bootloader entry point
 0xbfc05670|0x1fc05670: kernel image (670272/150561 bytes)
 0xbfc2a291|0x1fc2a291: ns image (147236/61298 bytes)
 0xbfc39203|0x1fc39203: loader image (144962/60533 bytes)
 0xbfc47e78|0x1fc47e78: init image (145731/60639 bytes)
 0xbfc56b57|0x1fc56b57: loc image (155848/65248 bytes)
 0xbfc66a37|0x1fc66a37: rd image (142805/59444 bytes)
 0xbfc7526b|0x1fc7526b: vfs image (166516/70073 bytes)
 0xbfc86424|0x1fc86424: fat image (211568/90576 bytes)
 0xbfc9c5f4|0x1fc9c5f4: initrd image (4286464/1243208 bytes)

Inflating components ... initrd fat vfs rd loc init loader ns kernel .
Copying CPU map ... 
Booting the kernel ... 
SPARTAN kernel, release 0.4.3 (Sashimi), revision 1486M (jakub@jermar.eu-20120430145154-dhc95fk7mhjlozgx)
Built on 2012-05-06 14:18:35 for mips32
Copyright (c) 2001-2012 HelenOS project
Detected 1 CPU(s), 32768 KiB free memory

######> Kernel panic on cpu0 due to a bad memory access while referencing address 0x00000038. <######
TLB Invalid Exception.

THE=0x80070000: pe=3 thr=0x00000000 task=0x80078000 cpu=0x80068000 as=0x80010000 magic=0xfacefeed
epc=0x8012794c  sta=0x00000002  lo =0x00000001  hi =0x00000000
a0 =0x00000038  a1 =0x00000000  a2 =0x00000003  a3 =0x80078000
t0 =0x1000a400  t1 =0x80111710  t2 =0x00000002  t3 =0xffffffe0
t4 =0xffffff80  t5 =0xfffff800  t6 =0x000000c0  t7 =0xffffffe0
t8 =0xffff0000  t9 =0x000000e0  v0 =0x80070000  v1 =0x00000003
s0 =0x00000038  s1 =0x80160000  s2 =0xffff8000  s3 =0x80077ef0
s4 =0x80190010  s5 =0x00000000  s6 =0x1399c267  s7 =0x80160000
s8 =0x80100000  at =0x00000000  kt0=0x00000002  kt1=0x00000000
sp =0x80077e30  ra =0x8012794c  gp =0x80000000

0x80077c90: generic/src/debug/stacktrace.o:stack_trace()+0x00000018
0x80077cb8: generic/src/debug/panic.o:panic_common()+0x00000170
0x80077d00: arch/mips32/src/mm/tlb.o:tlb_invalid()+0x00000134
0x80077d38: generic/src/interrupt/interrupt.o:exc_dispatch()+0x00000110
0x80077d80: arch/mips32/src/start.o:exception_handler()+0x000000f8
cpu0: halted

Change History (1)

comment:1 Changed 7 years ago by Jakub Jermář

Resolution: worksforme
Status: newclosed

Not reproducible as of mainline,1564. Closing as not reproducible.

Note: See TracTickets for help on using tickets.