Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 8 years ago

Closed 8 years ago

#371 closed defect (duplicate)

fread on devices makes the system unsuable

Reported by: Dominik Taborsky Owned by:
Priority: major Milestone: 0.5.0
Component: helenos/unspecified Version: mainline
Keywords: libc fread device Cc:
Blocker for: Depends on: libc
See also:

Description

Running fread() on block devices does not work, but it also somehow crashes parts of the system. The program that calls fread on devices in /loc/bd (maybe others as well) firstly crashes without bdsh noticing and then makes the shell output whitespace chars instead of the typed letters, prints tabs and makes the system generally unusable.

What is expected to happen: either proceed normally without crashing the program or inform the user about not implemented feature.

Steps to reproduce:
1: run qemu with an emulated harddrive
2: run ata_bd, which creates /loc/bd/ata1disk0 file
3: run fread /loc/bd/ata1disk0

Attachments (2)

fread.c (356 bytes) - added by Dominik Taborsky 8 years ago.
Makefile (1.6 KB) - added by Dominik Taborsky 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by Dominik Taborsky

Attachment: fread.c added

Changed 8 years ago by Dominik Taborsky

Attachment: Makefile added

comment:1 Changed 8 years ago by Dominik Taborsky

duplicate of #366

comment:2 Changed 8 years ago by Jakub Jermář

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.