Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#365 closed defect (worksforme)

Changing LED status bricks A4Tech keyboard

Reported by: Jiri Svoboda Owned by:
Priority: major Milestone: 0.5.0
Component: helenos/drv/usbhid Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

I have an A4Tech KB-5A Water-proof USB keyboard. The keyboard seems to be working fine except that if I press any of the lock keys (and thus LED status is updated) once or several (2-3) times, the keyboard stops responding - pressing any keys on it has no effect. I can observe this in HelenOS (connected via UHCI on my Sony Vaio laptop). I cannot see it when running Linux. The same machine (Vaio + HelenOS) but different USB keyboard works, so it seems to be a problem with HelenOS HID driver vs. A4Tech keyboard.

Change History (7)

comment:1 Changed 8 years ago by Vojtech Horky

Component: helenos/unspecifiedhelenos/drv/usbhid

This one?

Can you please, post output of usbinfo -rt? The keyboard might be using some weird HID descriptor that the current driver is not able to cope with.

BTW - does this happen on real hardware or in QEMU?

comment:2 Changed 7 years ago by Jakub Jermář

Is this still reproducible?

comment:3 Changed 7 years ago by Jakub Jermář

Milestone: 0.5.00.5.1

comment:4 Changed 7 years ago by Jiri Svoboda

Tried to test it, but as of mainline,1487, no USB devices work for me at all on bare metal (either Sony Vaio with UHCI or AMD workstation with OHCI).

comment:5 Changed 7 years ago by Jiri Svoboda

Yup, that's the one. Current link to product page I cannot get the usbinfo -rt right now since USB does not work for me at all on bare metal… will try forwarding to Qemu. AFAIR it uses standard descriptors for both keypress reports and setting LED state.

comment:6 Changed 7 years ago by Jiri Svoboda

Resolution: worksforme
Status: newclosed

I can no longer reproduce this as of mainline,1490. Yay :-)

comment:7 Changed 7 years ago by Jiri Svoboda

Milestone: 0.5.10.5.0
Note: See TracTickets for help on using tickets.