Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 8 years ago

Closed 8 years ago

#351 closed defect (fixed)

Mouse pointer does not move after switch to kernel console and back

Reported by: Martin Sucha Owned by:
Priority: major Milestone:
Component: helenos/unspecified Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

Background:

  • I compiled HelenOS with framebuffer settings for 1280x800
  • When booting, the mode switch probably failed
  • I don't see the HelenOS logo and terminal buttons

How to reproduce:

  • Move mouse, the pointer shows up and can be moved
  • Press F12 to switch to kernel console
  • Type continue
  • The mouse pointer shows up after a portion of a second at the spot it was before the switch to kernel console
  • The mouse pointer does not move, however.

Using PS/2 or USB mouse does not make a difference.

Change History (4)

comment:1 Changed 8 years ago by Martin Sucha

Also note that graphical console is used as the pointer is the graphical arrow.

comment:2 Changed 8 years ago by Jiri Svoboda

The same happens if you set resolution to 640x480. Looks like something goes wrong when we switch to kcon and back and VC buttons are not drawn.

comment:3 Changed 8 years ago by Jiri Svoboda

Fix in changeset:mainline,1039. Well, I know the support for mouse pointer when use_gcons is false is a little hackish, but I'll leave it for now. Console will undergo a more drastic rewrite anyway sooner or later, most probably when we implement a graphics server.

comment:4 Changed 8 years ago by Jiri Svoboda

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.