Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 8 years ago

Closed 7 years ago

#337 closed defect (worksforme)

ppc32 fb server failed assert in memory allocator

Reported by: Jiri Svoboda Owned by:
Priority: major Milestone: 0.5.0
Component: helenos/srv/fb Version:
Keywords: malloc Cc:
Blocker for: Depends on:
See also:

Description

As of changeset:mainline,927 tried to build ppc32 non-debug (since debug does not work). However, fb crashes with failed assertion in memory allocator code:

Assertion failed (area→magic == HEAP_AREA_MAGIC) at file 'generic/malloc.c', line 220.

See screenshot.

Attachments (2)

ppc32-fb-crash.png (19.9 KB) - added by Jiri Svoboda 8 years ago.
Screenshot of crashed FB server
ppc32-fb-crash-bt.png (19.9 KB) - added by Jiri Svoboda 8 years ago.
FB crash with backtrace

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by Jiri Svoboda

Attachment: ppc32-fb-crash.png added

Screenshot of crashed FB server

comment:1 Changed 8 years ago by Jakub Jermář

It would be useful to get the stacktrace once fb makes it to abort().

Changed 8 years ago by Jiri Svoboda

Attachment: ppc32-fb-crash-bt.png added

FB crash with backtrace

comment:2 Changed 8 years ago by Jakub Jermář

The stacktrace corresponds to:

   fb_client_connection() -> shm_handle() -> shm2pixmap() -> malloc()

comment:3 Changed 8 years ago by Jakub Jermář

I tested on mainline,1284 and was not able to reproduce the crash either with non-debug or debug. Can the submitter retest with the current mainline?

comment:4 Changed 8 years ago by Jakub Jermář

Keywords: malloc added

comment:5 Changed 7 years ago by Jakub Jermář

Resolution: worksforme
Status: newclosed

I am closing this as the issue does not seem reproducible. Please file a new ticket should the symptoms return in the mainline.

Note: See TracTickets for help on using tickets.