Fork us on GitHub Follow us on Google+ Follow us on Facebook Follow us on Twitter

Opened 7 years ago

Closed 7 years ago

#335 closed enhancement (fixed)

ppc32 kernel needs to be able to handle TLB misses caused by processing IRQ pseudocode

Reported by: Jakub Jermář Owned by: Martin Decky
Priority: major Milestone: 0.5.0
Component: helenos/kernel/ppc32 Version:
Keywords: Cc:
Blocker for: Depends on: #343
See also:

Description

The ppc32 kernel needs to be able to handle TLB misses caused by processing IRQ pseudocode.

The kernel should search the hierarchical page table while not holding the address space mutex. If there is a hit, the mapping is inserted into TLB and the processing is successful. A miss in this situation is a reason to panic the system or, if running in the context of the pseudocode owner task, kill the current task.

Change History (2)

comment:1 Changed 7 years ago by Martin Decky

Depends on: #343

comment:2 Changed 7 years ago by Jakub Jermář

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.