Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 9 years ago

Closed 8 years ago

#330 closed enhancement (invalid)

arm32 needs to be able to detect page misses caused by executing incorrect pseudocode

Reported by: Jakub Jermář Owned by: Jiri Svoboda
Priority: major Milestone: 0.5.0
Component: helenos/kernel/arm32 Version:
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

The arm32 kernel needs to be able to handle page faults caused by processing IRQ pseudocode. Note that if the pseudocode is correct, it is not expected to cause a page fault on arm32 so the only case we need to handle is when the pseudocode is not correct. Thus getting to a page fault handler on arm32 while processing IRQ pseudocode is a reason to panic the system or, if running in the context of the pseudocode owner task, kill the current task.

Also note that a failure to detect this situation will result in hitting an assertion and panicking anyway as soon as as_page_fault() attempts to lock a mutex.

Change History (1)

comment:1 Changed 8 years ago by Jakub Jermář

Resolution: invalid
Status: newclosed

Not applicable in current kernel which maps the physical addresses used by the pseudocode.

Note: See TracTickets for help on using tickets.