Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#321 closed defect (fixed)

Could not unmount FAT after `mv`

Reported by: Jakub Jermář Owned by: Jakub Jermář
Priority: major Milestone: 0.4.3
Component: helenos/srv/vfs Version:
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

The mv command is expected to fail on FAT because FAT does not support multiple hard links. However, attempting to rename a file residing on a FAT file system will result in rendering that file system not unmountable. How to reproduce on a TMPFS root file system:

/ # cd /tmp
/tmp # mkfile -s 2m image
/tmp # file_bd image fbd0
/tmp # mkfat fbd0
/tmp # fat
/tmp # mount fat /data fbd0
/tmp # cp /readme /data/r
/tmp # mv /data/r /data/r1
/tmp # unmount /data

unmount will report EBUSY (-15).

Change History (3)

comment:1 Changed 8 years ago by Jakub Jermář

I have already fixed this in lp:~jakub/helenos/fs. The problem is that vfs_rename() does not always drop the old_node reference.

comment:2 Changed 8 years ago by Jakub Jermář

Milestone: 0.5.00.4.3
Resolution: fixed
Status: newclosed

Fix merged in changeset:mainline,890.

comment:3 Changed 8 years ago by Jakub Jermář

Component: fs/fatsrv/vfs
Note: See TracTickets for help on using tickets.