Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 9 years ago

Closed 9 years ago

#256 closed defect (duplicate)

Assertion failed (idxp->pfc) at file 'fat_ops.c', line 295.

Reported by: Jakub Jermář Owned by:
Priority: major Milestone: 0.4.3
Component: helenos/fs/fat Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description (last modified by Jakub Jermář)

Running changeset:lp:~jakub/helenos/fs,165, which was merged into changeset:mainline,625 I occasionally hit the following assertion:

  Assertion failed (idxp->pfc) at file 'fat_ops.c', line 295.

when unlinking a file which is being written to (using the setup from ticket #255 + unlinking the large file at some point).

Attachments (2)

Screenshot-QEMU-1.png (25.6 KB) - added by Jakub Jermář 9 years ago.
Kernel console displaying the stack trace.
fat.disasm.bz2 (177.9 KB) - added by Jakub Jermář 9 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 9 years ago by Jakub Jermář

The corresponding line in fat_ops.c is from the beginning of fat_node_get_core():

       /*
         * We must instantiate the node from the file system.
         */

        assert(idxp->pfc);

        rc = fat_node_get_new(&nodep);
        ...

Changed 9 years ago by Jakub Jermář

Attachment: Screenshot-QEMU-1.png added

Kernel console displaying the stack trace.

Changed 9 years ago by Jakub Jermář

Attachment: fat.disasm.bz2 added

comment:2 Changed 9 years ago by Jakub Jermář

I have attached files required to reconstruct the whole stack trace.
From the stack trace, the calling sequence is:

fat_write() → fat_node_get_core() → assert()

comment:3 Changed 9 years ago by Jakub Jermář

Description: modified (diff)

comment:4 Changed 9 years ago by Jakub Jermář

Resolution: duplicate
Status: newclosed

I cannot reproduce this after jakub@…, so hopefully the root cause is the same. Closing as a duplicate.

Note: See TracTickets for help on using tickets.