Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 9 years ago

Closed 9 years ago

#198 closed defect (fixed)

UDP packets fail a checksum test when UDP checksum_computing is on

Reported by: Jakub Jermář Owned by:
Priority: major Milestone: 0.4.2
Component: helenos/net/udp Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

When cfg/net/general contains the following line:

UDP_CHECKSUM_COMPUTING=yes

udp_process_packet() will report invalid checksum and bail out.

Because of this, possible sockets waiting for this data will not be signaled and application such as nettest1 will appear hung.

This is reproducible only with the dp8390 and when UDP_CHECKSUM_COMPUTING=yes. Doing the same with UDP_CHECKSUM_COMPUTING=no or using the loopback interface does not reproduce the problem.

Steps how to reproduce:

  1. after system boot, start networking using netstart
  2. on one vc, start the echo server:

echo -v -p 8080 -t SOCK_DGRAM

  1. from another vc, run nettest1:

nettest1 -v -p 8080 -t SOCK_DGRAM 10.0.2.15

Change History (2)

comment:1 Changed 9 years ago by Jakub Jermář

There were some checksum-related changes in changeset:head,186.1.19.

comment:2 Changed 9 years ago by Jakub Jermář

Resolution: fixed
Status: newclosed

Fixed in changeset:head,312.

Note: See TracTickets for help on using tickets.