Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 9 years ago

Closed 9 years ago

#171 closed defect (duplicate)

Cannot build ia32

Reported by: Jakub Jermář Owned by:
Priority: critical Milestone: 0.4.2
Component: helenos-build/ia32 Version: mainline
Keywords: Cc:
Blocker for: Depends on:
See also:

Description

It is not possible to build the current head:

make[2]: Leaving directory `/home/jermar/software/H/uspace/srv/loader'
make[2]: Entering directory `/home/jermar/software/H/uspace/srv/loader'
/usr/local/ia32/bin/i686-pc-linux-gnu-gcc  -I../../lib/libc/include -O3 -imacros ../../lib/libc/../../../config.h -fexec-charset=UTF-8 -fwide-exec-charset=UTF-32LE -finput-charset=UTF-8 -ffreestanding -fno-builtin -nostdlib -nostdinc -Wall -Wextra -Wno-unused-parameter -Wmissing-prototypes -Werror-implicit-function-declaration -pipe -g -D__LE__ -march=pentium -D__32_BITS__ -Iinclude -c main.c -o main.o
/usr/local/ia32/bin/i686-pc-linux-gnu-gcc  -I../../lib/libc/include -O3 -imacros ../../lib/libc/../../../config.h -fexec-charset=UTF-8 -fwide-exec-charset=UTF-32LE -finput-charset=UTF-8 -ffreestanding -fno-builtin -nostdlib -nostdinc -Wall -Wextra -Wno-unused-parameter -Wmissing-prototypes -Werror-implicit-function-declaration -pipe -g -D__LE__ -march=pentium -D__32_BITS__ -Iinclude -c elf_load.c -o elf_load.o
/usr/local/ia32/bin/i686-pc-linux-gnu-as   -o interp.o interp.s
/usr/local/ia32/bin/i686-pc-linux-gnu-as   -o arch/ia32/ia32.o arch/ia32/ia32.s
/usr/local/ia32/bin/i686-pc-linux-gnu-ld -T arch/ia32/_link.ld main.o elf_load.o interp.o arch/ia32/ia32.o ../../lib/libc/libc.a -M -N ../../lib/softint/libsoftint.a -N -o loader -Map loader.map
/usr/local/ia32/bin/i686-pc-linux-gnu-ld: cannot open linker script file arch/ia32/_link.ld: No such file or directory

Change History (1)

comment:1 Changed 9 years ago by Jakub Jermář

Resolution: duplicate
Status: newclosed

Huh, this is just a duplicate of #170, I got into some trac-internal-error-reload trap.

Note: See TracTickets for help on using tickets.