Fork us on GitHub Follow us on Facebook Follow us on Twitter

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#122 closed defect (fixed)

Copying the tetris binary twice hangs the FAT file system

Reported by: Jakub Jermář Owned by:
Priority: major Milestone: 0.4.2
Component: helenos/fs/fat Version: mainline
Keywords: fs, fat Cc:
Blocker for: Depends on:
See also:

Description (last modified by Martin Decky)

With mainline,96, built for amd64 and fat, doing:

cp /app/tetris /srv/1
cp /app/tetris /srv/2

will hang the file system.

With HelenOS 0.4.1, the binary can be copied three times before FAT crashes during the fourth attempt in libblock hitting an assertion.

I think this is the same thing, given some new binaries having been added to the file system image recently (so it grew a little and the free space in it shrunk) and also a work in progress on the error handling front. The latter can explain the different symptom, because now the error will be propagated to the request initiator instead of causing an instant abort on assertion failure in libblock.

Change History (2)

comment:1 Changed 10 years ago by Jakub Jermář

Resolution: fixed
Status: newclosed

Fixed in: [head,98]
Root cause: Discrepancy between total sectors and number of sectors inferred from the size of the file allocation table.

comment:2 Changed 10 years ago by Martin Decky

Description: modified (diff)
Note: See TracTickets for help on using tickets.